Pular para o conteúdo principal

NameModel

Namespace: Lacuna.Pki.Issuer
Assembly: Lacuna.Pki
Class

public class NameModel

Hierarquia: object → NameModel

Construtores​

NameModel()​

public NameModel()

Propriedades​

BusinessCategory​

X.520 id-at-businessCategory

public string BusinessCategory { get; set; }

Retorno

string


CommonName​

X.520 id-at-commonName

public string CommonName { get; set; }

Retorno

string


Country​

X.520 id-at-countryName

public string Country { get; set; }

Retorno

string


Description​

X.520 id-at-description

public string Description { get; set; }

Retorno

string


DNQualifier​

X.520 id-at-dnQualifier

public string DNQualifier { get; set; }

Retorno

string


DomainComponent​

RFC 2247 id-domainComponent

public string DomainComponent { get; set; }

Retorno

string


EmailAddress​

PKCS #9 pkcs-9-at-emailAddress

public string EmailAddress { get; set; }

Retorno

string


GenerationQualifier​

X.520 id-at-generationQualifier

public string GenerationQualifier { get; set; }

Retorno

string


GivenName​

X.520 id-at-givenName

public string GivenName { get; set; }

Retorno

string


Initials​

X.520 id-at-initials

public string Initials { get; set; }

Retorno

string


Locality​

X.520 id-at-localityName

public string Locality { get; set; }

Retorno

string


Organization​

X.520 id-at-organizationName

public string Organization { get; set; }

Retorno

string


OrganizationalUnit​

X.520 id-at-organizationalUnitName

public ICollection<string> OrganizationalUnit { get; set; }

Retorno

ICollection<string>


OrganizationIdentifier​

X.520 id-at-organizationIdentifier

public string OrganizationIdentifier { get; set; }

Retorno

string


PostalCode​

X.520 id-at-postalCode

public string PostalCode { get; set; }

Retorno

string


Pseudonym​

X.520 at-pseudonym

public string Pseudonym { get; set; }

Retorno

string


SerialNumber​

X.520 id-at-serialNumber

public string SerialNumber { get; set; }

Retorno

string


StateName​

X.520 id-at-streetAddress

public string StateName { get; set; }

Retorno

string


StreetAddress​

X.520 id-at-streetAddress

public string StreetAddress { get; set; }

Retorno

string


Surname​

X.520 id-at-surname

public string Surname { get; set; }

Retorno

string


TelephoneNumber​

X.520 id-at-telephoneNumber

public string TelephoneNumber { get; set; }

Retorno

string


Title​

X.520 id-at-title

public string Title { get; set; }

Retorno

string


UnstructuredAddress​

PKCS #9 pkcs-9-at-unstructuredAddress

public string UnstructuredAddress { get; set; }

Retorno

string


UserId​

LDAP RFC 4519 uid / RFC 1274 userid

public string UserId { get; set; }

Retorno

string


Membros herdados​

ToString(), Equals(object), Equals(object, object), ReferenceEquals(object, object), GetHashCode(), GetType(), MemberwiseClone()

Ver em Markdown